Loading issues with Dashboards and Pipeline Analytics

Incident Report for Gem

Resolved

This issue should now be resolved, and we will continue to monitor performance.
Posted Nov 17, 2025 - 17:09 PST

Monitoring

Our team has been made aware of intermittent loading issues that are occurring with the Dashboards and Pipeline Analytics modules. We have deployed a fix and are continuing to monitor for performance stability.
Posted Nov 12, 2025 - 13:31 PST
This incident affected: Gem Web Application.