Website Performance Issues
Incident Report for Gem
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 10:51 PDT
Update
This should now be resolved!
Posted Oct 21, 2021 - 10:51 PDT
Investigating
We're currently investigating reports from some users experiencing general website slowness. We'll update this page as things progress.
Posted Oct 21, 2021 - 10:40 PDT
This incident affected: Gem Web Application.