Pages Loading Slowly Or Failing To Load
Incident Report for Gem
Resolved
A fix has been implemented and all Gem web pages are loading successfully now. We will continue to monitor the website for any problems.
Posted Nov 08, 2021 - 10:55 PST
Investigating
We are actively investigating an issue with pages on the Gem website loading slowly or failing to load.
Posted Nov 08, 2021 - 09:32 PST
This incident affected: Gem Web Application.